Humunkuli im HexManipu gefuneden

Antworten
rolfn
Beiträge: 1
Registriert: Fr 7. Nov 2014, 16:08
Wohnort: Duisburg
Humunkuli im HexManipu gefuneden

Beitrag von rolfn » Sa 8. Nov 2014, 10:58

Hallo,

ich habe einen kleinen Humunkuli im HexManipu im Zusammenhang mit WeichZwei gefunden.
Wenn ich dort für die Abschaltfunktion der Ausgänge den Off-Befehl der Zentrale abschalte, wird im EPROM der Wert in 0x000 auf A0 geändert.
Nun speichere ich das Hex-File und öffne es wieder. Jetzt ist der Haken bei Timeout des Dekoders nicht gesetzt.
Wer hat jetzt recht? :?: :?: :?:

cu
rolfn
Schönen Gruß

Rolf

Benutzeravatar
Sven
Administrator
Beiträge: 648
Registriert: Mo 7. Mär 2011, 14:13
Kontaktdaten:
Re: Humunkuli im HexManipu gefuneden

Beitrag von Sven » So 16. Nov 2014, 23:00

Hallo rolfn,

wenn im EEprom $00 ein "0a" steht, dann findet kein Abschalten durch Timeout statt.
wenn hingegen ein "a0" dort steht, wird der OFF Befehl der Zentrale ignoriert.

Entsprechend gibt es noch AA für "ignoriere beides" und ein "00" für "ignoriere nix".

Der Fehler liegt daher beim Einlesen des HEX, dort wird der Haken dann nicht richtig gesetzt. Ich werde dies korrigieren.

Sven

Benutzeravatar
Sven
Administrator
Beiträge: 648
Registriert: Mo 7. Mär 2011, 14:13
Kontaktdaten:
Re: Humunkuli im HexManipu gefuneden

Beitrag von Sven » Do 20. Nov 2014, 22:32

Hi,

Problem beseitigt mit HEX Manipulator 0.993

http://www.digital-bahn.de/bau_pic/hexm ... m#download

Sven

harterhund
Beiträge: 14
Registriert: So 18. Jan 2015, 20:38
Re: Humunkuli im HexManipu gefuneden

Beitrag von harterhund » Fr 17. Apr 2015, 20:21

Hallo Sven,
HEX Manipulator 0.993
Hier kann ich nur sagen : DANKE für deine Arbeit :)

Das ist Echt Super von dir :-)

MfG Frank


Antworten