Problem Justage Sand4

Link zum Projekt Sand: http://www.digital-bahn.de/bau_servo/sand.htm
Link zum Projekt Sand-Ei: http://www.digital-bahn.de/bau_servo/sandei.htm
Antworten
atc5fr
Beiträge: 1
Registriert: Fr 10. Okt 2014, 08:32
Problem Justage Sand4

Beitrag von atc5fr » Fr 10. Okt 2014, 08:44

Hallo allerseits,

ich habe ein Problem bei der Justage der Servos am Sand4. Die Anfangsposition lässt sich einwandfrei justieren, wenn ich aber die Endposition definieren wil, kann ich die Zeit nicht so weit zuück nehmen wie nötig. Das Problem liegt nicht am Servo: Ich kann die benötigten Zeiten im Manipu eintragen und dann brennen -> O.K. Mit der Justage-Platine funktioniert es aber nicht. Ich benötige ca 50µs Differenz, komme aber nicht unter 260µS. Das ganze ist für ein Car-System-Abzweig gedacht.

Grüße

Andreas

hillen02
Beiträge: 6
Registriert: Di 3. Mär 2015, 18:39
Wohnort: östliches Rhein-Main-Gebiet
Re: Problem Justage Sand4

Beitrag von hillen02 » Mi 4. Mär 2015, 18:46

Hallo Modellbahnfreunde,

ich schlage mich seit einigen Tagen mit dem gleichen Problem herum, das "atc5fr" am 10.Okt. 2014 hier im Forum beschrieben hat, leider bis heute ohne Antwort.
Der minimale Stellweg des Servos ist für meine Anwendung viel zu groß und läßt sich mit "Sand-Justage" nicht kleiner einstellen.

Ich habe darauf hin im Hex-Manipulator die min. Impulszeit auf 1,496 ms und die max. Impulszeit auf 1,504 ms eingestellt (Servo auf Mittelstellung). Dann den PIC gebrannt und den Dekoder angeschlossen. Der Servo steht tatsächlich auf Mittelstellung und führ auch, wie von mir gewünscht, auf Tastendruck (einprogrammierte Digitaladresse) keine Bewegung aus.

Jetzt habe ich versucht, mit "Sand-Justage" die gewünschten Enlagen einzustellen.
Ergebnis: Sobald man im Justagemodus ist und das erste mal eine Taste zur Endlageneinstellung drückt, beweg sich der Servo um ungefähr 20°. Das ist dann auch wieder der minimal einstellbare Drehwinkel des 90°-Servos, weniger ist einfach nicht möglich.

Nachdem ich die Prozedur mehrfach wiederholt habe, kam mir die idee, den PIC auszulesen.
Ergebnis bei mit "Sand-Justage" kleinstem Drehwinkel: min. Impulszeit 1,416 ms, max. Impulszeit 1,680 ms, diese Differenz von 264 ms entspricht bei einem 90°-Servo ungefähr 22° Stellweg.

Der Drehpunkt meines Servos liegt 2,5 cm unter dem Stellhebel der Weiche. Das bedeutet, der kleinste einstellbare Drehwinkel entspricht einem Stellweg von ca. 10 mm, ich benötige aber max. 4 mm.

Es ist mir wichtig, den Servo in Mittelstellung zu montieren und erst dann die beiden Endlagen aus dieser Mittelstellung heraus zu justieren.
So wird es ja auch von anderen Herstellern (z.B WA5 von Holtermann-Elektronik) empfohlen, und es verhindert vor allem, das der Servo beim ersten Einschalten durch zu starke unkontrollierte Ausschläge beschädigt wird.

Mache ich da jetzt einen Denkfehler ? Wenn ja, welchen ? Oder ist da in der Software eine Macke ?

Beste Grüße und DANKE für jeden Beitrag, der irgendwie zum Ziel führt

Helmut

hillen02
Beiträge: 6
Registriert: Di 3. Mär 2015, 18:39
Wohnort: östliches Rhein-Main-Gebiet
Re: Problem Justage Sand4

Beitrag von hillen02 » Do 5. Mär 2015, 11:40

Nachtrag zur Fehlerbeschreibung von gestern.

Sven Brandt hat mir heute meine Beobachtungen bestätigt und Abhilfe angekündigt. :D

Zitat aus dem Mail von Sven Brand:

Ich kann bestätigen, dass per
Justage der minimale Stellbereich (also das Delta zwischen LINKS und
RECHTS) bei 264 us war. Ich habe dies heute auf 48 us abgeändert. Kleinere
Werte haben hier wohl keinen Sinn, da sich dann der Servo zwar stark
erwärmt, aber eigentlich gar nicht bewegt. Wenn ich einen normalen
Stellbereich von der Impulsbreite für den Servo annehme, dann wären dies
in der Regel 1000 us (typischer Impulsbereich: 1 ms bis 2 ms). Somit habe
ich den minimalen Stellbereich nun von ca. 1/4 auf ca. 1/20 verkleinert.
Allerdings muss der Servo dann schon gut geeignet sein um solch keine
Stellwege vernünftig zu verarbeiten.

Die Software wird in den nächsten Tagen online gebracht ("großer Update
Tag" :-)

Grüße
Sven Brandt


Dann kann ich nur noch hoffen, das wir bald einen "großen Update Tag" erleben.

Beste Grüße
Helmut

Benutzeravatar
Sven
Administrator
Beiträge: 585
Registriert: Mo 7. Mär 2011, 14:13
Kontaktdaten:
Re: Problem Justage Sand4

Beitrag von Sven » Mi 25. Mär 2015, 23:20

Hallo

die Software V3.61 ist inzwischen online.

Sven


Antworten