Wald 2.1

Link zum Projekt:
WalD: http://www.digital-bahn.de/bau_wald/wald.htm
Lichtleiste: http://www.digital-bahn.de/bau_fdek/lichtleiste.htm
Antworten
Francois
Beiträge: 6
Registriert: Mi 17. Apr 2019, 09:26
Wald 2.1

Beitrag von Francois » Mi 17. Apr 2019, 09:38

Hallo Modellbahnfreunde

Ich beschäftige mich gerade mich Wald 2.1

Ein tolles Stück Hardware 😊
Viel flexibler als Wald 1.0 , kleiner mit Ladeschaltung einfach super

Leider Software mäßig komme ich nicht so klar.
Die Programmierung mit Pickit3 habe ich geschafft, war aber schwieriger als mit anderen PICs

Das Programmieren von CV und Schalten geht am Anfang . Leider schient sich der PIC manchmal zu verfangen und dann geht überhaupt nicht mehr
Nur eine NEU Programmierung des PIC ermöglicht dann wieder die Funktion
Diesen Cyklus habe ich jetzt ein parr mal durchgemacht

Vielleicht ist nur S/w noch nicht ganz fertig oder der PIC 18324 ist viel sensibler als ich es von anderen Projekten Fips, Weich1,2 S88 gewöhnt bin.

Vielleicht nur abwarten das eine neue Software Version kommt ?
Oder mache ich irgendetwas falsch ?

Mfg aus Grenoble

Francois

Benutzeravatar
Hatschepsut
Beiträge: 518
Registriert: Di 8. Mär 2011, 15:30
Wohnort: Rendsburg
Re: Wald 2.1

Beitrag von Hatschepsut » Do 18. Apr 2019, 13:36

Hallo Francois,

Deine Beobachtung kann ich bestätigen. Nach einigen CV-Änderungen kann es vorkommen, daß der Dekoder nicht mehr ansprechbar ist (Fehler in der Dekoder -Adresse - kurze/lange Adresse) :o .
Die Firmware hat aber auch noch Beta-Status V<1.0
Von daher Abwarten! :roll:

Gruß
Hans-Jürgen
H0, 2L=, GBMBoost/GBM16, (ST4 - IO24 - GBM16TS - Control8SC - WaLD2.1 alle eigene Layouts), WaLD, LED-Decoder, Weich88-N, SMS88-N, Einsatz, Snoopy, DSD2010 m. Anzeige

Francois
Beiträge: 6
Registriert: Mi 17. Apr 2019, 09:26
Re: Wald 2.1

Beitrag von Francois » Fr 19. Apr 2019, 20:50

Hallo Hans Jürgen

Danke alles klar
Werde mich an Baustellen meiner Anlage zuwenden :D und abwarten


Mfg
Francois

Stef
Beiträge: 3
Registriert: Di 15. Mär 2011, 14:15
Re: Wald 2.1

Beitrag von Stef » Mi 24. Jul 2019, 11:34

Hallo Francois,

ich habe mit meinen WaLD-2.1_Platinen genau die gleichen Probleme wie Du. Swen hatte mir eine ausführliche Beschreibung via E-Mail gesandt, aus der auch die ganzen CVs hervorgehen; das nützt mir allerdings wenig, wenn z.B. ein Reset (in CV8 den Wert 64 schreiben) nicht funktioniert. :o

Ich werde Swen direkt anschreiben, weil sich - neben Deinen Schwierigkeiten - bei mir auch keine CVs auslesen lassen (ich habe eine Lenz LZV100-Zentrale, SW-Version 3.6); ebenso funktioniert Programming-on-the-main auch nicht.

Wie hast Du den PIC an Deinen Pickit (den habe ich auch) angeschlossen? :?:

Viele Grüße aus Hamburg

Stef

Francois
Beiträge: 6
Registriert: Mi 17. Apr 2019, 09:26
Re: Wald 2.1

Beitrag von Francois » So 4. Aug 2019, 21:13

Hallo Stef

ich habe Sven auch schon vor den Ferien angeschrieben

es sollte eine Interferenz mit dem MFX Signal geben, der den Dekoder in einen unansprechbaren Zustand bringt
(bei mir geht wie bei dir das CV auslesen auch nicht mehr)

Sven schickte mir ein F/W das leider das problem auch nich loeste
aber ich galube er ist jetzt in Ferien

Das Problem wird sich sicher loen lassen

mfg aus Grenoble

Stef
Beiträge: 3
Registriert: Di 15. Mär 2011, 14:15
Re: Wald 2.1

Beitrag von Stef » Fr 16. Aug 2019, 11:41

Hallo Francois,

eine Frage von mir hattest Du nicht beantwortet:

Wie hast Du den PIC an Deinen Pickit (den habe ich auch) angeschlossen? :?: Verwendet Du eine spezielle Klemme?

Sven schrieb mir, man bräuchte zum Programmiere den PicKit3, der PicKit2 sei ungeeignet... Den werde ich mir dann wohl besorgen müssen.

Viele Grüße

Stef

Francois
Beiträge: 6
Registriert: Mi 17. Apr 2019, 09:26
Re: Wald 2.1

Beitrag von Francois » Sa 17. Aug 2019, 22:30

Hallo Stef

verzeihe , das stimmt

also ich habe mir einen Pickit 3 besorgt und programmiere mit Mlab X , das ganze ist aber ziemlich zickig aber ich habe es dann irgendenwie hingekriegt

Zur verbindung loete ich einfach an den Punkten von Wald 2.1 den Ausgang des Pickit 3

mfg aus Grenoble

Benutzeravatar
Hatschepsut
Beiträge: 518
Registriert: Di 8. Mär 2011, 15:30
Wohnort: Rendsburg
Re: Wald 2.1

Beitrag von Hatschepsut » So 18. Aug 2019, 21:28

Hallo hier mal ein Anschlussschema:

Bild

Gruß
Hans-Jürgen
H0, 2L=, GBMBoost/GBM16, (ST4 - IO24 - GBM16TS - Control8SC - WaLD2.1 alle eigene Layouts), WaLD, LED-Decoder, Weich88-N, SMS88-N, Einsatz, Snoopy, DSD2010 m. Anzeige

Stef
Beiträge: 3
Registriert: Di 15. Mär 2011, 14:15
Re: Wald 2.1

Beitrag von Stef » Do 22. Aug 2019, 07:20

Hallo Francois,
hallo Hans-Jürgen,

vielen Dank für Eure Infos. Jetzt werde ich - wie gesagt - mir erst einmal den PicKit3 besorgen, und dann mal sehen, ob das mit dem Programmieren funktioniert.

Viele Grüße aus dem Norden

Stef

Francois
Beiträge: 6
Registriert: Mi 17. Apr 2019, 09:26
Re: Wald 2.1

Beitrag von Francois » Do 22. Aug 2019, 12:48

Hallo Stef

Wenn du genau auf das PCB schaust findest du sogar dafür Lötpunkte : LOG1 und 2 , 5V, GNd etc
Nur VPP fehlt, das kannst leicht an der richtigen Seite von R2 anlöten wenn du nicht gerne am PIC selber lötest

MFG aus Grenoble


Antworten