Wald 2.1

Link zum Projekt:
WalD: http://www.digital-bahn.de/bau_wald/wald.htm
Lichtleiste: http://www.digital-bahn.de/bau_fdek/lichtleiste.htm
Stef
Beiträge: 5
Registriert: Di 15. Mär 2011, 14:15
Re: Wald 2.1

Beitrag von Stef » Mi 28. Aug 2019, 11:33

Hallo Francois,

das waren genau die Angaben, die mir noch fehlten! :D

Merci Francois. Ich werde berichten, ob die Umprogrammiererei etwas gebracht hat.

Viele Grüße aus Hamburg

Stef

Benutzeravatar
Hatschepsut
Beiträge: 531
Registriert: Di 8. Mär 2011, 15:30
Wohnort: Rendsburg
Re: Wald 2.1

Beitrag von Hatschepsut » So 22. Sep 2019, 10:00

Hallo,

Sven hat V0.83 online gestellt :D .

Gruß
Hans-Jürgen
H0, 2L=, GBMBoost/GBM16, (ST4 - IO24 - GBM16TS - Control8SC - WaLD2.1 alle eigene Layouts), WaLD, LED-Decoder, Weich88-N, SMS88-N, Einsatz, Snoopy, DSD2010 m. Anzeige

Stef
Beiträge: 5
Registriert: Di 15. Mär 2011, 14:15
Re: Wald 2.1

Beitrag von Stef » Fr 27. Sep 2019, 09:51

Moin zusammen,

nachdem inzwischen der PicKit 3 bei mir eingetroffen ist und Sven die Software auf 0.83 aktualisiert hat (Danke Sven :D), habe ich die PICs neu gebrannt und dazu eine Art Schnittstelle in die Wagen implementiert - Danke nochmals an Francois und Hatschepsut! Wenn's interssiert, poste ich ein Bild, wie ich das gemacht habe.

Mit MPLABX 5.25 und meinem Windows 10-Rechner funktioniert das Programmieren einwandfrei; bitte beachtet, dass der PIC 16F18324 über den PicKit-Porgrammer mit Strom versorgt werden muss, ansonsten funktioniert das Brennen nicht. Einstellen tut man das unter:

Project Properties->Conf: [default]->PICKit 3, dann unter "Option Categories" den Punkt "Power" anwählen und ein Häkchen bei "Power target circuit from PICKit3" setzen.

Viele Grüße aus dem Norden

Stef

digifahrer
Beiträge: 3
Registriert: So 17. Feb 2019, 16:07
Re: Wald 2.1

Beitrag von digifahrer » Mi 25. Dez 2019, 10:21

Hallo Zusammen,

wenn ich das Häkchen bei "Power target circuit from PICKit3 gesetztt habe welche Spannung muss ich einstellen?
5V?

Für eine Antwort besten Dank.

Joe

Benutzeravatar
Sven
Administrator
Beiträge: 613
Registriert: Mo 7. Mär 2011, 14:13
Kontaktdaten:
Re: Wald 2.1

Beitrag von Sven » Sa 28. Dez 2019, 01:27

Hallo,

ja. 5V

Es wird mit dem MPLab auch die "MPLAB IPE" angeboten:

https://www.microchip.com/mplab/mplab-i ... nvironment

das ist dann nicht das "ganz große" Software Paket, geht für PicKit3 und PicKit4.

Bein PicKit4 muss die Platine leider an der Versorgungsspannung hängen. Es muss hier dann in der IPE unter "Power" noch auf "Use High Volt Programm Mode Entry" ungeschaltet werden. Dann unter "Operate" -> "Connect" und File laden und "Program" drücken

Sven


Antworten