WALD 2.1 - Neonstarten

Link zum Projekt:
WalD: http://www.digital-bahn.de/bau_wald/wald.htm
Lichtleiste: http://www.digital-bahn.de/bau_fdek/lichtleiste.htm
Antworten
jens.sieder
Beiträge: 1
Registriert: So 17. Mai 2020, 14:49
WALD 2.1 - Neonstarten

Beitrag von jens.sieder » So 17. Mai 2020, 15:00

Hallo Sven,

ich habe nun inzwischen die neue Waggonlichtleiste aufgebaut. Mir erscheint das Starten mit Neoneffekt nicht ausgeprägt genug. Erst musste ich die Fade-Funktion ausschalten. Dann schaltet die LED nicht wirklich aus bei Startflackern, sondern schaltet zwischen zwei Helligkeitsstufen. Durch Ändern der Hellungkeitseinstellungen in CV 160 ff. konnte ich den Effekt verbessern und jedoch nur dann, wenn die Dimmfunktion F7 eingeschatlet ist.
Nun meine Frage: Habe ich ein Denkfehler? Warum schaltet die LED nicht zischen heller Stufe und aus?

Viele Grüße
Jens

Benutzeravatar
Sven
Administrator
Beiträge: 645
Registriert: Mo 7. Mär 2011, 14:13
Kontaktdaten:
Re: WALD 2.1 - Neonstarten

Beitrag von Sven » Fr 5. Jun 2020, 11:44

HI,

weil Neon Lampen auch nicht zwischen Hell und Dunkel toggeln beim Einschalten. Auch bei "Dunkel" ist die Neon Röhre an den Enden etwas am leuchten.

Im Moment wird die PWM bei "Dunkel" während des Einschalt-Flackerns einfach halbiert, weil "Aus" mit zu sehr nach "Strobo" oder "Disko" ausgesehen hat. Und würde ich hier mit dem DIMM-PWM Wert arbeiten, dann könnte ein gedimmter Ausgang ja ebenfalls nicht mehr flackern (da er zwischen "gedimmt und "gedimmt" hin- und herschalten würde)

Demnach müsste man noch 2 CVs einführen,
- "Dunkel-Phase Neon Einschalten @ LED=HELL"
- "Dunkel-Phase Neon Einschalten @ LED=gedimmt"

Und dass dann für jeden Ausgang (die können ja auch unterschiedlichen PWM Werte für HELL und GEDIMMT haben). Deshalb wurde die Sache mit "PWM Halbieren" abgekürzt.

Sven


Antworten